등록일 2011-01-19 13:54:13 조회수 1180
제목 [공지] 그누보드 취약점 발견 주의
□ 개요
o 국내 PHP기반의 공개 웹 게시판인 그누보드에서 XSS, CSRF 취약점이 발견됨[1]
o 취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 관리자 계정 탈취 및
악성코드 유포지로 악용되는 등의 피해를 입을 수 있으므로 웹 관리자의
적극적인 조치 필요

□ 해당시스템
o 영향받는 소프트웨어[1]
- 그누보드 4.32.15 및 이전 버전

□ 해결방안
o 그누보드 4.32.15 및 이전버전 사용자는 4.33.00버전으로 업데이트[1]
※ 패치 작업 이전에 원본 파일은 백업 필요
※ 덮어쓰기 방식의 패치를 적용하기 힘든 경우, 홈페이지[1]에
“===중요===”부분을 참조하여 조치
o 그누보드를 새로 설치하는 이용자
- 반드시 보안패치가 적용된 최신버전(4.33.00)을 설치

□ 용어 정리
o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
o XSS (Cross Site Scripting) : 웹사이트 관리자가 아닌 이가 웹페이지에
클라이언트 사이드 스크립트를 삽입하여 다른 사용자가 이를 실행하게끔
허용하는 취약점
o CSRF (Cross-Site Request Forgery) : 권한을 도용하는 가짜 요청문이
클라이언트의 웹브라우저상에서 실행되도록 유도 가능한 취약점
o 그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임워크

□ 기타 문의사항
o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118


[참고사이트]
[1] http://sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=5540